Levertine

Please login or register.

Author Topic: Possible Bug? Media dropdown menu  (Read 2142 times)

lurk

  • Full Member
  • ***
  • Posts: 113

Possible Bug? Media dropdown menu
« on: January 17, 2015, 02:02:18 PM »
Thanks Pete for the release of 1.1.0 really neat work.

Though I've just noticed that when viewing a embedded youtube video, the dropdown Media menu is hidden underneath the video.  Not sure if it was like this before, to be honest I hadn't noticed it whilst testing.
Guitarist Guild Running SMF 2.0.9 / Tinyportal 1.1 and Levertine Gallery

Arantor

  • Levertine Developer
  • Full Member
  • *
  • Posts: 248

Re: Possible Bug? Media dropdown menu
« Reply #1 on: January 17, 2015, 02:06:33 PM »
Which browser? Some browsers have issues with z-indexes of iframes vs other elements on the apge, especially IE. Chrome for example behaves as expected.

lurk

  • Full Member
  • ***
  • Posts: 113

Re: Possible Bug? Media dropdown menu
« Reply #2 on: January 17, 2015, 02:08:27 PM »
Sorry Pete, I was just about to edit my post with that info..  You can probably guess IE11 again.  ;)
Guitarist Guild Running SMF 2.0.9 / Tinyportal 1.1 and Levertine Gallery

Arantor

  • Levertine Developer
  • Full Member
  • *
  • Posts: 248

Re: Possible Bug? Media dropdown menu
« Reply #3 on: January 17, 2015, 04:54:59 PM »
I can fix that for IE11 for YouTube, not sure about other video embeds. Basically, iframes are generally problematic but the best way to embed content.

lurk

  • Full Member
  • ***
  • Posts: 113

Re: Possible Bug? Media dropdown menu
« Reply #4 on: January 17, 2015, 05:00:41 PM »
Cheers, I'm sure you'll sort it the best way possible.  I can't ask more than that.  ;)
Guitarist Guild Running SMF 2.0.9 / Tinyportal 1.1 and Levertine Gallery

Arantor

  • Levertine Developer
  • Full Member
  • *
  • Posts: 248

Re: Possible Bug? Media dropdown menu
« Reply #5 on: January 17, 2015, 05:13:24 PM »
A quick test for Vimeo and DailyMotion seemed to work in IE11 properly so this will be fixed when I do the next release since I already patched YT in.

lurk

  • Full Member
  • ***
  • Posts: 113

Re: Possible Bug? Media dropdown menu
« Reply #6 on: January 17, 2015, 05:19:31 PM »
See, I knew you'd do it.  :ninja:

Thank you.
Guitarist Guild Running SMF 2.0.9 / Tinyportal 1.1 and Levertine Gallery

Arantor

  • Levertine Developer
  • Full Member
  • *
  • Posts: 248

Re: Possible Bug? Media dropdown menu
« Reply #7 on: January 18, 2015, 08:37:49 AM »
I've updated to SVN trunk here, see if it works properly for you now.

lurk

  • Full Member
  • ***
  • Posts: 113

Re: Possible Bug? Media dropdown menu
« Reply #8 on: January 18, 2015, 10:25:34 AM »
I've updated to SVN trunk here, see if it works properly for you now.

Thanks, it's fine now.  :ninja:
Guitarist Guild Running SMF 2.0.9 / Tinyportal 1.1 and Levertine Gallery

Arantor

  • Levertine Developer
  • Full Member
  • *
  • Posts: 248

Re: Possible Bug? Media dropdown menu
« Reply #9 on: January 18, 2015, 10:31:00 AM »
Awesome :)

Arantor

  • Levertine Developer
  • Full Member
  • *
  • Posts: 248

Re: Possible Bug? Media dropdown menu
« Reply #10 on: January 19, 2015, 09:09:25 AM »
1.1.1 is now out, so this can probably be filed as resolved :)
 

SMF 2.0.9 | SMF © 2014, Simple Machines
BlueLight design by Bloc